Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Spur 1 Gemeinschaftsforum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

  • »Wolfgang Heesch« ist ein verifizierter Benutzer
  • »Wolfgang Heesch« ist der Autor dieses Themas

Beiträge: 96

Wohnort: Elmshorn

Beruf: Ingenieur Fahrzeugtechnik

  • Nachricht senden

1

Mittwoch, 16. November 2016, 16:22

Leerlauf- oder Lastgeräusch und "Segeln" individuell einstellbar...

...ist jetzt mit einer neuen Beta-Testversion 4.5.0 der ESU-Lokprogrammersoftware möglich.
Das funktioniert ohne Eingriffe in den Soundablauf.

Gestestet habe ich es bisher an dem (zur Bearbeitung gesperrten) Soundfile der KM1-V100 - funktioniert tadellos.
Bergfahrt, Talfahrt, Rollen mit Leerlaufsound, alles per F-Tasten simulierbar.
Sogar volle Last am Berg und trotzdem die Lok langsamer werden lassen geht.
Oder andersherum, Einfrieren der Geschwindigkeit, und dann den Sound per Regler steuern, geht auch.
Ein neues Sound- und Betriebsprogramm ist nicht erforderlich.
Mehr F-Tasten eigentlich auch nicht, denn man kann diese Funktionen auch auf bereits belegte, nur im Stand benötigte Tasten mappen (Ansagen und Schaffnerpfiff z.B.).

Näheres gibt es im ESU-Forum.
Noch ein Hinweis: in der Soundbearbeitung gibt es unter dem Menüpunkt "Bearbeiten" die neue Option "Am Raster ausrichten".
Die sollte erst einmal ausgeschaltet bleiben, weil es noch nicht immer optimal funktioniert.
Viele Grüße aus Elmshorn
Wolfgang

2

Mittwoch, 16. November 2016, 16:44

Danke für die Infos.
Gute Sache, wenn`s klappt.

Bin leider nicht im ESU Forum, was bedeutet "zur Bearbeitung gesperrten Soundfile"?
Nur die von der Lok ausgelesenen CV?
Oder braucht man die komplette KM1 Datei, die für meinen eigenen Decoder verschlüsselt ist?

Beiträge: 2 170

Wohnort: Erfurt

Beruf: jetzt Rentner, programmieren nur noch im Hobby

  • Nachricht senden

3

Mittwoch, 16. November 2016, 18:25

was bedeutet "zur Bearbeitung gesperrten Soundfile"?
Das bedeutet, die Soundfiles sind mit einem Passwort verschlüsselt, so dass man keine Möglichkeit hat, den Soundbereich mit den Soundslots zu bearbeiten oder auch nur anzuschauen.
Damit kann ein Hersteller sein Soundfile schützen und es trotzdem per Download jedem zur Verfügung zu stellen.
Wer die ESU Lokprogrammer- Software hat, kann das ja mal mit einem offenen Soundfile selbst ausprobieren und es verschlüsseln.
Es geht sogar noch mehr, man kann auch ein Soundfile so verschlüsseln, das es nur auf einen bestimmten Decoder aufzuspielen geht über die Seriennummer des Decoders.
MfG. Berthold

  • »newfield60« ist ein verifizierter Benutzer

Beiträge: 59

Wohnort: Burgenland, Österreich

Beruf: Techniker

  • Nachricht senden

4

Donnerstag, 17. November 2016, 14:56

Hallo Wolfgang,

weißt Du eventuell, ob es auch möglich ist, einfach den Decoderteil einer Lok auzulesen, die neuen Funktionen zu mappen, und dann wieder auf den Decoder runterzuschreiben (wobei dann sowieso die Decoder-Firmware aktualisiert wird)?
Das wär natürlich überhaupt der Hammer, denn von den Herstellern kriegt man wahrscheinlich nicht immer ein gesperrtes File zugeschickt, das ist ja auch Aufwand für die...

Hallo Oliver,

Du bist da viel tiefer drin in der Materie als ich: Besteht ein Risiko, dass z.B. bei einer KM-1 Lok etwas nicht mehr funktioniert, wenn man die Decoder-Firmware auf diese Version aktualisiert?

LG
Peter

5

Donnerstag, 17. November 2016, 15:04

Hallo Peter,

ich komme derzeit zu nix abgesehen vom Hauptjob, es geht auf Weihnachten zu ...
Bisher habe ich die Beta-V4.5.0 noch nicht einmal gesehen.

ESU hat, meine ich, den Hinweis herausgegeben, dass man mit der Firmware nicht zurück gehen kann.
Kann aber auch sein, dass ich da was verwechsle ...
Schöne Grüße vom Oliver.

  • »newfield60« ist ein verifizierter Benutzer

Beiträge: 59

Wohnort: Burgenland, Österreich

Beruf: Techniker

  • Nachricht senden

6

Donnerstag, 17. November 2016, 15:39

Servus Oliver,

das war aber eine Express-Antwort :-)

schön, dass bei Euch vor Weihnachten das Geschäft "brummt"!

ESU hat bei der Beta-V4.5.0 folgenden Hinweis angebracht: "Bitte beachten: Da die Decoderfirmware automatisch angehoben wird, kann ein derart programmierter Decoder mit einer älteren LokProgrammer Software nicht mehr gelesen werden. Sie müssen in diesem Fall erst einen "Downgrade" des Decoders erzwingen und neu aufspielen."

So ein Downgrade sollte also irgendwie gehen...
In dem Falle wäre dann die Frage, ob Du von allen KM1 Loks mit V4.0 Decoder die Files zur Verfügung hast, um ggf. nach einem Fehlschlag und notwendigem Downgrade nochmal das originale File draufspielen zu können?


LG
Peter

7

Donnerstag, 17. November 2016, 16:28

Hallo Peter,

Nein, ich habe nur einige wenige Soundfiles, ohne Anlass bekomme ich die auch nicht.
Schöne Grüße vom Oliver.

Beiträge: 2 170

Wohnort: Erfurt

Beruf: jetzt Rentner, programmieren nur noch im Hobby

  • Nachricht senden

8

Donnerstag, 17. November 2016, 18:48

Sie müssen in diesem Fall erst einen "Downgrade" des Decoders erzwingen und neu aufspielen."
Hallo,
bisher hat ein Downgrade bei mir immer funktioniert, wenn ich z.B. Decoder mit allerneuester Software bekam, selbst aber nur die vorherige Lokprogrammer-Version auf meinem Rechner hatte.
Aber eine Garantie wird es wohl nicht geben.
MfG. Berthold

  • »Wolfgang Heesch« ist ein verifizierter Benutzer
  • »Wolfgang Heesch« ist der Autor dieses Themas

Beiträge: 96

Wohnort: Elmshorn

Beruf: Ingenieur Fahrzeugtechnik

  • Nachricht senden

9

Freitag, 18. November 2016, 01:05

Hallo zusammen,

prinzipiell ist es so gedacht:

Neue Software 4.5.0 im Rechner öffnen.
Neues Projekt öffnen, auf richtigen Decodertyp achten.
Decoderdaten ( natürlich nicht den Sound) vom Decoder auslesen und ins Projekt übernehmen.
CVs 114 und 115 einstellen.
Im Funktionsmapping "Lastbetrieb" und "Leerlaufbetrieb" einpflegen.
NUR Decoderdaten (AUF KEINEN FALL Sounddaten) auf den Decoder schreiben. Wer eine zittrige Hand an der PC-Maus hat . . .

Nun sind die neuen Features für das vorhandene, ansonsten unberührte Soundfile anwendbar.

Dabei wird dann natürlich zwangsweise die Firmware auf den neuesten Stand aktualisiert.
Letzteres beinhaltet zwei große Fallstricke:

- zum EInen benutzten einige Hersteller spezielle Firmwareversionen mit besonderen Features, die damals in den ESU-Programmen noch nicht enhalten waren. Ich vermute hier Besonderheiten bei älteren Projekten im Bereich z.B. der Verdampferansteuerung oder dem Lichtmapping. Das würde dann mit einer ESU-Firmware wahrscheinlich nicht mehr funktionieren.

- weiterhin sind die aktuellen ESU - "Softwares" (?) nicht beliebig abwärtskompatibel.
Frühere Versionen haben eine unsaubere Programmierung noch toleriert, ab einer bestimmten Version aber (ich vermute mal die 4.4.8, bin mir aber derzeit hier sehr unsicher) kommt deswegen eine Fehlermeldung, und das Schreiben wird abgebrochen.

Unter den Voraussetzungen, dass:

1. die Firmware einem veröffentlichten ESU-Standard entspricht, und
2. die auf dem Decoder vorhandene Firmware kompatibel ist, also einer Version entspricht, die ab der Software vermutet 4.4.8 (Oliver, weißt du das noch, ab wann der letzte Übergang nach Container-Init keine Bedingung mehr haben durfte?) mitgeliefert wurde,

sollte obige Prozedur klappen.

Recht sicher bin ich mir hier nur bei der KM1-V100, denn das von ESU frei veröffentlichte File hat sowohl die gleichen Gimmicks als auch die gleichen Soundfehler, die ich bei der KM1-V100 schon live gehört habe.

Bei allen anderen Loks kann man nur mit dem Programmer die Firmwareversion aus der Lok auslesen und dann mit den ESU-Firmwareversionen vergleichen. Stimmen sie (genau!!!) überein (und sind nicht älter als - na ja, geschätzt die zur 4.4.8 gehörige - OLIVER!), dürfte es keine Probleme beim Firmwareupdate geben - ansonsten Finger weg!

Irgendwo gab es mal eine Tabelle, welche die Frimwareversion den LoPro-Softwareständen zuordnet. Hat die jemand?


Zu der neuen 4.5.0, die mittlerweile von ESU offiziell herausgegeben wurde, kann ich jetzt nur sagen, dass das angebotene File "verdächtig klein" ist und von meinem Rechner als "file corrupted" nicht akzeptiert wurde.
Die zuletzt von mir getestete "450 beta2 Build 16319" läuft bei mir aber einwandfrei, bis auf das gewöhnungsbedürftige Einfangen der Grafik am Raster.
Das Einrichten des sog. "BW-Modus" bei Dampfloks auf Tastendruck dauerte sage und schreibe nur 3 Minuten... .

So, eine gute Nacht euch allen!

P.S.: ein Firmware-Downgrade an sich ist immer ohne Probleme machbar - der Hinweis bezieht sich darauf, dass man es eben selbst manuell anstoßen muss.
Nur, das nützt ja auch nichts, wenn z.B. KM1 eine Firmware verwendet hatte, die ESU nicht "offiziell veröffentlicht" hat.
Viele Grüße aus Elmshorn
Wolfgang

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Wolfgang Heesch« (18. November 2016, 01:18)


  • »newfield60« ist ein verifizierter Benutzer

Beiträge: 59

Wohnort: Burgenland, Österreich

Beruf: Techniker

  • Nachricht senden

10

Freitag, 18. November 2016, 09:59

Hallo Wolfgang,

wann bitte schläfst Du eigentlich ;-)?

Danke für die sehr ausführliche Antwort!

Der Hinweis auf die von ESU gelisteten Firmwareversionen für die Decoder ist eine ausgezeichnete Idee. Vorausgesetzt wir finden diese "Tabelle"...

LG
Peter

Beiträge: 2 170

Wohnort: Erfurt

Beruf: jetzt Rentner, programmieren nur noch im Hobby

  • Nachricht senden

11

Freitag, 18. November 2016, 17:56

Zu der neuen 4.5.0, die mittlerweile von ESU offiziell herausgegeben wurde, kann ich jetzt nur sagen, dass das angebotene File "verdächtig klein" ist und von meinem Rechner als "file corrupted" nicht akzeptiert wurde.
Hallo Wolfgang,
der Fehler ist inzwischen von ESU korrigiert worden. Ich hab schon die neue 4.5er Version installiert (keine beta).
MfG. Berthold

  • »Wolfgang Heesch« ist ein verifizierter Benutzer
  • »Wolfgang Heesch« ist der Autor dieses Themas

Beiträge: 96

Wohnort: Elmshorn

Beruf: Ingenieur Fahrzeugtechnik

  • Nachricht senden

12

Freitag, 18. November 2016, 21:42

Danke für die Info!

Im Programmordner der ESU-Software findet man die Firmwareversionen - hier mal als Beispiel die für den XL4.0 und den XL4.1.
Das sollten eigentlich die veröffentlichten sein - Gegenprüfung würde ich aber empfehlen.
Eventuell liegt da zwischen 4.0 und 4.1 auch der "Break" in der Kompatibilität. Nur eine Vermutung allerdings, wäre aber logisch.
»Wolfgang Heesch« hat folgendes Bild angehängt:
  • LSXL4 Firmware.JPG
Viele Grüße aus Elmshorn
Wolfgang

13

Freitag, 18. November 2016, 23:23

Guten Abend,

jetzt mal für die nicht ganz so firmen mit Firmware usw. . . . . .bedeutet das ich kann meine KM1 Loks mit 4.0er Dekoder wie die 18,3 oder Br01 NBK mit diesen Features ausrüsten ? Da ich "nur" ein BW zuhause habe, wäre Segeln auf Knopfdruck natürlich ein Traum.

Danke für nähere infos.

LG Uwe

Beiträge: 179

Wohnort: Bernried

Beruf: Schaumstoffexperte für die Automobilindustrie.

  • Nachricht senden

14

Samstag, 19. November 2016, 06:50

Leerlauf bzw. Segeln

Hallo Uwe,

das geht schon seit längeren mit ZIMO-Decoder.
Insbesondere die "Lokfahrt" Funktion so wie Matthias Henning sie programmiert ist ganz toll gemacht. Einige leichte Dampfschläge und schon rollt die Lok davon.
Meine KISS 01 habe ich so umgebaut.

Sowas wünscht man sich direkt vom Hersteller anstatt Bahnhofsdurchsagen usw.

Auch logische Schaltfolgen wären nicht schlecht, z.B. zuerst die Lichtmaschine einschalten und dann erst die Beleuchtung.
Das gleiche gilt für die Zufallsgeräusche, die Speisepumpe sollte im Stand niemals zu hören sein denn die wird nur bei der Fahrt benutzt.
Ich weiss, es gibt immer weniger Leute die wissen wie eine Dampflok funktioniert, deshalb stört es wohl die Wenigsten aber andererseits wäre es auch ein Lerneffekt.

Schönes Wochenende,

Alain

15

Samstag, 19. November 2016, 09:57

Guten Abend,

jetzt mal für die nicht ganz so firmen mit Firmware usw. . . . . .bedeutet das ich kann meine KM1 Loks mit 4.0er Dekoder wie die 18,3 oder Br01 NBK mit diesen Features ausrüsten ? Da ich "nur" ein BW zuhause habe, wäre Segeln auf Knopfdruck natürlich ein Traum.

Danke für nähere infos.

LG Uwe
Hallo Uwe,

bin seit zwei Tagen mit diesen neuen Funktionen am ausprobieren.
Zu deiner Frage: ja, genau das geht und es ist relativ einfach zu programmieren.

Grüße, Karl

16

Samstag, 19. November 2016, 10:23

Hallo Karl,

danke für die Antwort. Wäre es vermessen zu bitten, wenn du weisst wie es geht es mitzuteilen ?

Vielen Dank im Voraus

Uwe

17

Samstag, 19. November 2016, 10:43

Hallo Karl,

danke für die Antwort. Wäre es vermessen zu bitten, wenn du weisst wie es geht es mitzuteilen ?

Vielen Dank im Voraus

Uwe
Hallo Uwe,

ist eigentlich alles in den Beiträgen 1 und 9 von Wolfgang sehr gut beschrieben.
Dem braucht man nichts mehr hinzufügen.
Etwas Übung im Umgang mit dem Lokprogrammer sollte man aber schon haben.

Grüße
Karl

18

Samstag, 19. November 2016, 11:00

Hallo Karl,

danke. Dann werde ich es mal versuchen. Ich war mir njicht sicher ob's das war . . .


Gruss Uwe

19

Montag, 21. November 2016, 22:55

Hallo Spur1er,

ich habe auch die neue Lokprogrammer-Software 4.5.0 ausprobiert, nur ein Test auf meinem Probe-Prüf-Stand.
Das hört sich sehr gut an, am Sonntag werde ich einen Test mit einer Dampflok auf der Mannheimer Anlage machen.
Muss aber noch meine eigenen Sound-File bearbeiten, dürfte aber kein Problem sein.
(Wenn ich genug Zeit habe mache ich auch ein Video davon.)

Grüße
Gerhard

20

Dienstag, 22. November 2016, 11:25

Guten Tag,

ich habe gestern beide Funktionen (lastbetreib und leerlauf) bei meiner 01 NBK mit einem Sound File eines bekannten Soundspezialisten ;-) eingepfegt und die auf den beiden F Tasten liegenden Soundfiles herausgenommen. Leider passiert nichts, außer das nach drücken der F Taste lastbetrieb die Lok nicht mehr fährt. Bei Leerlauf bleibt alles beim Alten.

Wo liegt mein Fehler?

Und ich hätte noch eine generelle Frage: geht das auch bei 3.5er Dekodern? Oder eben nur bei den 4er Dekodern?

Vielen Dank
Uwe

Ähnliche Themen